Caller ID is still not showing up?

Comment on Asterisk and UK Caller ID
HarvSki
Joined: Sun 29 of Jan, 2006

Caller ID is still not showing up always on Sangoma A200

Posted:Wed 27 of Dec, 2006 (10:24 UTC)
Thanks Martin, turning up the gain worked for me on a Sangoma A200 card, here is my working zapata.conf for the Sangoma

cidsignalling=v23
cidstart=polarity
callerid=asreceived
usecallerid = yes
;For your incoming BT line connected to an FXO module (red)
immediate=yes ; will take the line on the first ring
context = from-zaptel
;switchtype = national
echocancel = yes
echocancelwhenbridged = yes
echotraining = yes
;add the is option if you are problems with DTMF detection
;relaxdtmf = yes
rxgain = 6.0
txgain = 6.0
signalling = fxs_ks
group = 0
channel => 1-2
language=en
callgroup=1
nothinman
Joined: Fri 23 of Jun, 2006

Caller ID is still not showing up?

Posted:Fri 23 of Jun, 2006 (11:39 UTC)
Sometimes you're getting CID, sometimes not. The reason is simple, but I was trying to resolve this issue for a couple of days now...
Anyway. The problem seems to be line quality, or actually attenuation.

If it still doesn't work for you try to modify zapata.conf adding following lines:

rxgain=15.0
txgain=5.0

Depending on your line length, quality and many other things you basically have to try different rxgain parameters. If it's too high it won't accept DTMF tones. If it's too low CID won't work.
I suggest you start with 5 and try to increase it by 5... so 5, 10, 15 and so on.

Good luck,
Martin