Inbound disconnects after 30 seconds

iperez_genius
Joined: Tue 29 of Jul, 2008

Re: Inbound disconnects after 30 seconds

Posted:Thu 07 of Aug, 2008 (01:11 UTC)
i have a very similar problem...my calls are directed to the IVR (auto attendant) if i hangup during the call the IVR continues until its finished...also not sure what i am doing wrong
midstar
Joined: Mon 04 of Aug, 2008

Re: Inbound disconnects after 30 seconds

Posted:Mon 04 of Aug, 2008 (15:39 UTC)
Here's some more information:

I tried the same test with another voip provider, and I DONT get the same problem. But, when I test Gafachi by having a softphone receive the call, it works fine - I can stay connected more than 30 seconds.

So the problem only seems to happen when I'm using FreeSwitch with Gafachi.

Here is how I have the SIP profile configured:

<include>
<gateway name="gafachi-in">
<param name="username" value="xxxxxxxxxxxxxxx"/>
<param name="password" value="xxxxxxxxxxxxxxx"/>
<param name="register" value="true"/>
<param name="register-transport" value="udp"/>
<param name="retry_seconds" value="10"/>
<param name="expire-seconds" value="600"/>
<param name="caller-id-in-from" value="false"/>
<param name="realm" value="sip.gafachi.com"/>
<param name="proxy" value="sip.gafachi.com"/>
<!--extra sip params to send in the contact-->
<param name="contact-params" value="tport=tcp"/>
</gateway>
</include>
kasteris
Joined: Thu 03 of Jul, 2008

Re: Inbound disconnects after 30 seconds

Posted:Mon 04 of Aug, 2008 (13:23 UTC)
.
midstar
Joined: Mon 04 of Aug, 2008

Inbound disconnects after 30 seconds

Posted:Mon 04 of Aug, 2008 (11:44 UTC)
Another question. I'm using Gafachi for inbound calls. When a call comes in, regardless of what it's doing, ie playing a prompt, bridging a call to another number, etc, the inbound call always gets disconnected after 30 seconds. My python script handling the call seems to keep running when this happens, but the line is hungup.

I think it is a configuration issue - anybody know what would cause this?

Thanks.