Yate + CUCM

tbs
Joined: Tue 16 of Jun, 2009

Re: Yate + CUCM

Posted:Sat 02 of Jun, 2012 (14:14 UTC)
Well.. I could.. but three years passed and that computer were formated couple of times xD

But dont worry, I will try new ways soon with CUCM interconnecting with Avaya G300 and G200 and maybe yate.. with PSTN phones, H323 phones and Cisco phones..
That will be fun.. Stay tuned :)
diana
Joined: Wed 28 of Apr, 2004

Re: Yate + CUCM

Posted:Fri 01 of Jun, 2012 (08:03 UTC)
Can you please post the regexroute.conf.
vir
Joined: Thu 27 of Jan, 2005

Re: Yate + CUCM

Posted:Fri 19 of Jun, 2009 (06:05 UTC)
503 Service Unavailable from cisco can be caused by a bunch of reasons. For example, if service-policy is configured on an interface, but bandwidth is not configured or qos requirements can not be satisfied. See www.cisco.com for that.

Welcome to #yate on freenode with yate-related questions!
tbs
Joined: Tue 16 of Jun, 2009

Yate + CUCM

Posted:Tue 16 of Jun, 2009 (23:23 UTC)
Hi,
I am trying to create a small Cisco-Yate (SCCP-SIP-H323) phone network. I have installed an Cisco Unified Communications Manager 7 on one computer and Yate on another. There is no problem in configuring Cisco CUCM, but configuration of Yate is not easy. There is almost none documentation and nobody explain anything anywhere. I want to be able to call from H.323 phone to SIP (or SCCP) phone . I understand, that H.323 phone is need to be registered at Yate and SIP or SCCP is at CUCM. I have problem at interconnecting Yate and Cucm. I hope it should looks like ""H.323 phone -> Yate -> CUCM -> SIP/SCCP phone"".
H.323 phone is connected to Yate and I am able to make Yate-Yate calls (also CUCM-CUCM calls).. but I can't call on SIP (or SCCP) phone on CUCM form H.323 phone and every try end with "SIP/2.0 503 Service Unavailable" and "Routing failed" info from cucm.
I could have bad routing set, but is here anyone, who could explain to me, what menas .*=sip/sip:\0@192.168.1.80 ??? I dont understand specifically "sip/sip:\0" part.
Does anyone have working configuration? Any help appreciated

Here is some info:
IP's:
Cisco Unified CM - 192.168.1.80 
Yate - 192.168.1.29
H.323 phone - 192.168.1.30 (set at phone) and pal (name registered at Yate)
(Cisco 7920) SCCP phone - calling number 13 (set at CUCM)

here is some log info:
<sip:INFO> Sending 'INVITE sip:13@192.168.1.80' 010C1A20 to 192.168.1.80:5060
------
INVITE sip:13@192.168.1.80 SIP/2.0
Max-Forwards: 20
Via: SIP/2.0/UDP 192.168.1.29:5060;rport;branch=z9hG4bK213784580
From: "pal [192.168.1.30]" <sip:anonymous@192.168.1.29>;tag=742460441
To: <sip:13@192.168.1.80>
Call-ID: 408069251@192.168.1.29
CSeq: 2 INVITE
User-Agent: YATE/1.2.0
Contact: <sip:anonymous@192.168.1.29:5060>
Allow: ACK, INVITE, BYE, CANCEL, REFER, OPTIONS, INFO
Content-Type: application/sdp
Content-Length: 231

v=0
o=yate 1245107862 1245107862 IN IP4 192.168.1.29
s=SIP Call
c=IN IP4 192.168.1.29
t=0 0
m=audio 19664 RTP/AVP 4 8 0 101
a=rtpmap:4 G723/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
------
<sip:INFO> Received 316 bytes SIP message from 192.168.1.80:5060
------
SIP/2.0 100 Trying
Date: Mon, 15 Jun 2009 23:17:42 GMT
From: "pal [192.168.1.30]" <sip:anonymous@192.168.1.29>;tag=742460441
Allow-Events: presence
Content-Length: 0
To: <sip:13@192.168.1.80>
Call-ID: 408069251@192.168.1.29
Via: SIP/2.0/UDP 192.168.1.29:5060;rport;branch=z9hG4bK213784580
CSeq: 2 INVITE

------
<sip:INFO> Received 410 bytes SIP message from 192.168.1.80:5060
------
SIP/2.0 503 Service Unavailable
Date: Mon, 15 Jun 2009 23:17:42 GMT
Warning: 399 "Routing failed: ccbid=10 socket=192.168.1.29:5060"
From: "pal [192.168.1.30]" <sip:anonymous@192.168.1.29>;tag=742460441
Allow-Events: presence
Content-Length: 0
To: <sip:13@192.168.1.80>;tag=1049044373
Call-ID: 408069251@192.168.1.29
Via: SIP/2.0/UDP 192.168.1.29:5060;rport;branch=z9hG4bK213784580
CSeq: 2 INVITE

------
<sip/2:ALL> YateSIPConnection::hangup() state=1 trans=010AE4D8 error='noconn' code=503 reason='Service Unavailable' [010BF458]