Polycom IP550 / IP320 MWi Message Indicator Not Working

robfantini
Joined: Thu 16 of Aug, 2007

Re: Polycom IP550 / IP320 MWi Message Indicator Not Working

Posted:Tue 20 of Jul, 2010 (20:47 UTC)
Thank you, you info helped solver our MWI not working issue.

for some reason

/var/spool/asterisk/voicemail/default exists
and
/var/spool/asterisk/voicemail/device does not.

On our older 1.4 system one of these directories was a symlink to the other .

On an AsteriskNow 1.7 fresh install this exists: /var/spool/asterisk/voicemail/device

On our new Asterisk 1.6 system , installed from source on Debian , this exists : /var/spool/asterisk/voicemail/default

I suspect that another solution is:

ln -s /var/spool/asterisk/voicemail/default /var/spool/asterisk/voicemail/device

OR if you already have a /var/spool/asterisk/voicemail/device :
ln -s /var/spool/asterisk/voicemail/device /var/spool/asterisk/voicemail/default
jukka
Joined: Sat 01 of Aug, 2009

Re: Polycom IP550 / IP320 MWi Message Indicator Not Working

Posted:Sat 01 of Aug, 2009 (19:37 UTC)
I got it working. It came down to the settings in the FreePBX. When setting up SIP extension and under mailbox as default the setting is for
mailbox = 813@device
when I changed it to
mailbox = 813 <extension>

and
<mwi msg.mwi.1.subscribe="813" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="*97"

the system started working. This applies to both IP550 and IP320. It did not seem to matter whether the SIP entension config if the type = peer or type = friend.

hope that this helps someone.
jukka
Joined: Sat 01 of Aug, 2009

Polycom IP550 / IP320 MWi Message Indicator Not Working

Posted:Sat 01 of Aug, 2009 (11:55 UTC)
My problem is that I cannot get IP320 and IP550 MWi message lamp indicator working. I have searched forums, read articles, trialed large number of settings without luck. Articles include
http://www.voip-info.org/wiki/view/Getting+MWI+on+Polycom+Phones+to+work+with+Asterisk
SureTeQ Polycom Setup Guide

But I cannot find a solution, perhaps you can help.

First of all I have the following setup in the Asterisk (I am using Elastix 1.5.2-2) for the messages (under extensions):
mailbox: 813@device
Voicemail password: 813
Email address: myemail@ourdomain.com
VM Context: default

My IP550 has the following config for the MWi

<msg msg.bypassInstantMessage="1">
<mwi msg.mwi.1.subscribe=""
msg.mwi.1.callBackMode="contact"
msg.mwi.1.callBack="*97"
msg.mwi.2.subscribe=""
msg.mwi.2.callBackMode="disabled"
msg.mwi.2.callBack=""
msg.mwi.3.subscribe=""
msg.mwi.3.callBackMode="disabled"
msg.mwi.3.callBack=""
msg.mwi.4.subscribe=""
msg.mwi.4.callBackMode="disabled"
msg.mwi.4.callBack=""
/>
</msg>

My IP320

<msg msg.bypassInstantMessage="1">
<mwi msg.mwi.1.subscribe="" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="*97"
msg.mwi.2.subscribe="" msg.mwi.2.callBackMode="registration" msg.mwi.2.callBack=""

I have also trialed setting in the sip.cfg
up.mwiVisible="1"
up.mwiVisible="0"

My IP550 has SIP 3.1.3.0439, and IP320 SIP SIP 3.1.3.0439

When I press the message button on the phone, the phone connects to the Asterisk voicemail and after entering the password 813 I can listen the new messages. When experimenting the settings
msg.mwi.1.callBack="*97" setting seems to define the phone number for this button, but then why this setting would be under mwi section on the Polycom phones?

Has anyone ady ideas or configuration examples? Must be something simple that I have got wrong. I am not sure how the Poycom SIP phone accesses the voicemail on asterisk, using SIP profile. Does my setting need some other voicemail box address and password?

Thank you very much.
Best regards,
Jukka