OrkAudio Debian Lenny

Joined: Mon 04 of Jan, 2010

Re: OrkAudio Debian Lenny

Posted:Mon 04 of Jan, 2010 (12:52 UTC)
Hi, try to create symbolic link to new library file.
First view what files is need for orkaudio to run, with command:
  1. ldd /usr/sbin/orkaudio
then you see something like that:
linux-gate.so.1 => (0xffffe000)
libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0xb7f57000)

libACE.so.5.4.2 => not found <------------------- this one u need to link, i do that by command # ln -s /usr/lib/libACE-5.6.3.so /usr/lib/libACE.so.5.4.2

libxerces-c.so.26 => /usr/lib/libxerces-c.so.26 (0xb7bfc000)
liblog4cxx.so.9 => /usr/lib/liblog4cxx.so.9 (0xb7b1a000)
liborkbase.so.0 => /usr/lib/liborkbase.so.0 (0xb7b00000)
libstdc.so.5 => /usr/lib/libstdc.so.5 (0xb7a46000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7a24000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7a18000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb78ea000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb78d8000)
libstdc.so.6 => /usr/lib/libstdc.so.6 (0xb77f2000)
/lib/ld-linux.so.2 (0xb7fbc000)

And everything is worked fine for me.
I hope this helps.
Sorry for my poor english skills:)
Joined: Wed 28 of Oct, 2009

OrkAudio Debian Lenny

Posted:Wed 28 of Oct, 2009 (19:04 UTC)
Has anyone gotten orkaudio to run on Debian Lenny. It keeps asking for shared libraries (i.e. libACE.5.4.2.so) - There are newer versions of this shared library installed. I am trying to find older ones but have had no luck. Could someone provide some light...

Thank you very much for the help.