Caller can't hear agent, MOH continues after agent answers queue call

sean456
Joined: Thu 05 of Nov, 2009

Re: Caller can't hear agent, MOH continues after agent answers queue call

Posted:Thu 05 of Nov, 2009 (09:51 UTC)
Please Help me for proper configuration & Installation of Astrik Step by Step in Centos

Sean Cruz
buy forclosed homes
millsu2
Joined: Fri 30 of Oct, 2009

Caller can't hear agent, MOH continues after agent answers queue call

Posted:Fri 30 of Oct, 2009 (19:11 UTC)
This is an odd problem, and I cannot figure out the cause. I also can't duplicate it, it just happens randomly. Usually things work just fine, but occasionally when an agent answers a call from the queue, the caller cannot hear the agent. The agent cannot be heard in the recorded call or when monitoring the call. Other times, the agent can be heard but is very faint. There has also been a couple of times when the agent answered and the MOH didn't stop and the on hold messages continued to play.

I have sip debug on, asterisk debug set to 1, and the verbosity set to 5 and haven't been able to find anything different between these calls and the calls that work normally, but I'm not really sure what to look for. Does anyone else have any ideas? Currently I have only seen this problem when callers call a specific extension. The extension is identical to a number of other extensions in the dialplan other than the extension number and a couple of user defined variables. The same queue handles calls from multiple extensions, but none of the otherextensions seem to have this problem.

Thanks to anyone that can help!

Asterisk from source, 1.6.1.1
Asterisk and agent devices are on the same network. Incoming calls come into asterisk on a different network, no NAT.
Agent devices are Polycom Soundpoimt 301 using sip.ld ver 3.1.3.0439