Does not return from konference call

llimit
Joined: Tue 26 of Jan, 2010

Does not return from konference call

Posted:Wed 27 of Jan, 2010 (10:00 UTC)
Hi folks!
I hope I'm on the correct forum and someone can help me with my issue I am experiencing atm.
On my * 1.6.2 I have a Konference running with a various number of members. Now i'd like a 'bot' to join that konference to a specific point of time.
I tried to realise that by writing a script, which moves a call file to asterisks /var/spool/asterisk/outgoing with this content:

Channel: Local/8001@default
MaxRetries: 2
RetryTime: 60
Context: default
Extension: 8001
Priority: 1

The relevant part of the extensions.conf looks like this:

exten => 8001,1,Konference(meeting1)
exten => 8001,2,wait(2)
exten => 8001,3,Playback(sounds/announce)
exten => 8001,4,Hangup

So as you can see, the 'bot' is supposed to join the conference, say its announcement and leave afterwards.
Unfortunately, however, the extension flow never makes it to 8001,2 for some reason.
This is what the log shows when moving the call file to the outgoing folder:

*CLI> konference list
Name                 Members              Volume
meeting1              1                    0
//---- moving call file ---- //
*CLI>     -- Attempting call on Local/8001@default for 8001@default:1 (Retry 1)
    -- Executing [8001@default:1] Konference("Local/8001@default-8d21;2", "meeting1") in new stack

*CLI> konference list
Name                 Members              Volume
meeting1              2                    0
//---- some waiting time here... ---- //
*CLI> [Jan 27 10:54:28] NOTICE[10967]: pbx_spool.c:339 attempt_thread: Call failed to go through, reason (3) Remote end Ringing

*CLI> konference list
Name                 Members              Volume
meeting1              1                    0


I really hope someone can help me, because i just dont know what to do :(

Thanks a lot and greetings,
Alex