Zaptel extension disconnect issue

ajemo
Joined: Tue 09 of Mar, 2010

Re: Zaptel extension disconnect issue

Posted:Mon 05 of Apr, 2010 (17:55 UTC)
I just wanted to follow up on my own issue in case it could help somebody else.

It turns out I could get rid of the busy signal by changing the signalling option in the zaptel.conf and zapata.conf files. You have to change the signalling option to match in both files, otherwise you will cripple your PBX. I changed my signalling from fxo loop start to fxo kewl start.

On a seperate but related issue, we were still receiving a quick millisecond busy signal clip at the end of calls made from the PBX side through the rhino channel bank to analogue lines. This happened when the caller on the PBX side hung up first (the analogue end would hear the clip). This turned out to be a timing issue. In the zaptel.conf file there is a "span" option. it read as follows:

span=2,0,0,esf,b8zs

We changed it to be:

span=2,1,0,esf,b8zs

the difference is the second zero was changed to a "1". This changes the timing to come from another device rather than within the T1 card (perhaps the rhino box). For some reason this sloved the problem.

P.S. Any changes made to the zaptel.conf and zapata.conf files require an asterisk reboot before they become effective.
ajemo
Joined: Tue 09 of Mar, 2010

Zaptel extension disconnect issue

Posted:Tue 09 of Mar, 2010 (21:56 UTC)
We have a PBXtra server with at Sangoma T1 PCI card installed. A Rhino channel bank connects calls made on zaptel extensions to PSTN ports. My issue is that whenever a call is made from an IP phone on our network to an analogue phone sitting on one of these Rhino FXS channels, and a hangup is initiated by the IP phone side, the analogue line hears an endless busy signal. Is there any solution to this through the zapta.conf or zaptel.conf or some other configuration?