need help on compiling astersik-addons??? urgent

bluenet
Avatar
Joined: Mon 10 of May, 2010

Re: need help on compiling astersik-addons??? urgent

Posted:Mon 02 of Aug, 2010 (03:19 UTC)
Hi,
I think something wrong with your .h files, especially in the Bluetooth directory. It’s better to Add my MSN account to know more.
My msn account: bluenet2010@hotmail.com
alimoni
Joined: Tue 09 of Feb, 2010

need help on compiling astersik-addons??? urgent

Posted:Thu 29 of Jul, 2010 (05:24 UTC)
Hi all.
I really need to use asterisk realtime with SQL but when I try to install asterisk-addons to create "res_config_mysql.so" it halts at "make" command , and the result isas below:

[root@localhost asterisk-addons]# make
CC="gcc" CXX="g++" LD="" AR="" RANLIB="" CFLAGS="" make -C menuselect CONFIGURE_SILENT="--silent" makeopts
make[1]: Entering directory `/root/Desktop/Asterisk/Asterisk16/asterisk-addons/menuselect'
make[1]: `makeopts' is up to date.
make[1]: Leaving directory `/root/Desktop/Asterisk/Asterisk16/asterisk-addons/menuselect'
make[1]: Entering directory `/root/Desktop/Asterisk/Asterisk16/asterisk-addons/channels'
   [CC] chan_mobile.c -> chan_mobile.o
chan_mobile.c: In function `handle_cli_mobile_search':
chan_mobile.c:561: error: `HANDSFREE_AGW_PROFILE_ID' undeclared (first use in this function)
chan_mobile.c:561: error: (Each undeclared identifier is reported only once
chan_mobile.c:561: error: for each function it appears in.)
make[1]: *** [chan_mobile.o] Error 1
make[1]: Leaving directory `/root/Desktop/Asterisk/Asterisk16/asterisk-addons/channels'
make: *** [channels] Error 2
[root@localhost asterisk-addons]#




after getting this error, I tried to copy "res_config_mysql.so" to my modules directory, but I couldnt find it.
what can I do ? because it is really urgent for me to integerate an asterisk with mysql.

I have compiled following packages on my CentOS 4.5(everything installed):

zaptel-1.4.12.1.tar.gz
LibPRI 1.4.11.3
Asterisk 1.6.2.10 or 1.6.2.9 (i`m not sure)
but when I try to make "Add-Ons 1.6.2.1" I get what I described above.


my host OS info:
CentOS 4.5 with everything installed.


( bytheway where should I look for "res_config_mysql.so" to copy manually? )