click noises on E1 calls

txoroa
Joined: Thu 18 of Nov, 2010

[SOLVED]Re: click noises on E1 calls

Posted:Wed 24 of Nov, 2010 (13:56 UTC)
Hi, we solved it. The problem was on the sync source configured for the span in the /etc/dahdi/system.conf
it was set to 0 when the correct value was 1 (source on the far end)

hope this will help anyone in the future.

txoroa
Joined: Thu 18 of Nov, 2010

Re: click noises on E1 calls

Posted:Thu 18 of Nov, 2010 (12:39 UTC)
Hi again,
We removed the echo canceller but we still hear de glitch (so, it seems the echocanceller has nothing to do on this)
Hehe, i'll try to describe de noise. Tt is almost like a heartbeat but the first tac is almost inaudible.

Any hint?
Thanks!
txoroa
Joined: Thu 18 of Nov, 2010

click noises on E1 calls

Posted:Thu 18 of Nov, 2010 (11:16 UTC)
Hi,
We have a TE121 for external communications withing our freepbx system. It has the hardware echo canceller. (Wildcard TE121 (VPMADT032))
All internal calls work perfectly. External calls are also working but remote speaker can hear a glitch each second.
Searching digium documentation for this issue we found this answer on the FAQ:
>>>>>>Why am I getting a clicking noise?
>>>>>>If a clicking noise is present when dialing through an FXO or when getting dialtone from an FXS, this is cause by echotraining. Turn it off to get rid of the clicking. The click is necessary for the echotraining.

As read in the forums, we tried to disable the echotraining (using include). The chan_dahdi is configured this way:
; [span_1]
signalling=pri_cpe
switchtype=euroisdn
pridialplan=unknown
prilocaldialplan=unknown
group=0
context=from-pstn
channel=1-15,17-31
echocancel=yes
echotraining=no



We also looked for system errors related to interrupts...etc. but everything seems to be ok. The voice and sound in fact is absolutely great. The problem is that glitch wich is very anoying igf there is a silence.

any hint about this??
Thanks!!!