PRI Signalling down!

nihaty
Joined: Sat 10 of Sep, 2011

PRI Signalling down!

Posted:Sat 10 of Sep, 2011 (13:55 UTC)
Dear All,

I am a starter on Freeswitch although I have telecoms experience for a long time

I am trying to set-up a Freeswitch server with a Digium TE110P ISDN PrI E1 card.

I have installed DAHDI Drivres and the card is discovered OK.

I have also installed the libpri library and activated mod_freetdm. When I run the freeswitch I can see that my span is defined when I connect disconnect the cable I recieve alarms as below

2011-09-10 16:47:27.948506 [NOTICE] mod_freetdm.c:1819 Alarm raised on channel 1:1
2011-09-10 16:47:27.948506 [WARNING] ftmod_libpri.c:1419 channel 1:1 (1:1) has alarms! [BLUE]
2011-09-10 16:47:27.948506 [NOTICE] mod_freetdm.c:1819 Alarm raised on channel 1:2
2011-09-10 16:47:27.948506 [WARNING] ftmod_libpri.c:1419 channel 1:2 (1:2) has alarms! [BLUE]
.
.
.
2011-09-10 16:47:27.948506 [NOTICE] mod_freetdm.c:1819 Alarm raised on channel 1:30
2011-09-10 16:47:27.948506 [WARNING] ftmod_libpri.c:1419 channel 1:30 (1:30) has alarms! [BLUE]
2011-09-10 16:47:27.948506 [NOTICE] mod_freetdm.c:1819 Alarm raised on channel 1:31
2011-09-10 16:47:27.948506 [WARNING] ftmod_libpri.c:1419 channel 1:31 (1:31) has alarms! [BLUE]


The problem I have is no matter what I do signalling_status is always DOWN. 


freeswitch@voip.cybetech.com> ftdm list

+OK
span: 1 (GSMChannelBank)
type: isdn
physical_status: ok
signaling_status: DOWN
chan_count: 31
dialplan: XML
context: public
dial_regex: 
fail_dial_regex: 
hold_music: 
analog_options: none


I have changed various settings in the configuration files but there is no change. my conf files are as follows:

/etc/dahdi/system.conf:

span=1,0,0,ccs,hdb3
bchan=1-15,17-31
dchan=16
loadzone        = us
defaultzone     = us

freetdm.conf:


[general]
cpu_monitor => no
cpu_monitoring_interval => 1000
cpu_set_alarm_threshold => 80
cpu_reset_alarm_threshold => 70
cpu_alarm_action => warn

debugdtmf_directory=/usr/local/freeswitch/log/

[span zt GSMChannelBank]
trunk_type => E1
b-channel => 1-15
d-channel => 16
b-channel => 17-31

freetdm.conf.xml:


<configuration name="freetdm.conf" description="FreeTDM Configuration">

        <settings>
                <param name="debug" value="0"/>
        </settings>


   <libpri_spans>
     <span name="GSMChannelBank">
        <param name="switch" value="euroisdn"/>
        <param name="mode" value="net"/>
        <param name="debug" value="none"/>

        <param name="dialplan" value="XML"/>
        <param name="context" value="public"/>
      </span>
   </libpri_spans>

</configuration>



I will appreciate if anyone can advise where I shall look for the solution.

Regards,

Nihat Yilmaz