Asterisk on Ubuntu Breezy v5.10

Asterisk on Ubuntu Breezy (v5.10)!


While Ubuntu has Asterisk in the distros, it is an old version at 1.0.9. In order to get the latest version compiled and running, you must first obtain and compile the libraries required for Asterisk:

  • Openssl & -devel
  • Ncurses & -devel
  • Zlib & -devel

To do this, you must have gcc v3.4 and run this command as sudo/root:

apt-get install cvs make gcc g++ libncurses5-dev libssl-dev zlib1g-dev

Once this is complete, you may follow the standard installation instructions from Asterisk.org.

Solution source: geekaction.com

Asterisk on Ubuntu Breezy (v5.10)!


While Ubuntu has Asterisk in the distros, it is an old version at 1.0.9. In order to get the latest version compiled and running, you must first obtain and compile the libraries required for Asterisk:

  • Openssl & -devel
  • Ncurses & -devel
  • Zlib & -devel

To do this, you must have gcc v3.4 and run this command as sudo/root:

apt-get install cvs make gcc g++ libncurses5-dev libssl-dev zlib1g-dev

Once this is complete, you may follow the standard installation instructions from Asterisk.org.

Solution source: geekaction.com
Created by: muppetmaster, Last modification: Fri 04 of Dec, 2009 (04:58 UTC) by admin
Please update this page with new information, just login and click on the "Edit" or "Discussion" tab. Get a free login here: Register Thanks! - Find us on Google+