ZTDummy - zttest returns negative values

Joined: Mon 02 of Mar, 2009

ZTDummy - zttest returns negative values

Posted:Mon 02 of Mar, 2009 (14:00 UTC)
I am attempting to install ztdummy to act as a timing source for MeetMe conferencing within Asterisk (1.4). I am running Debian 5.0 (lenny), 2.6.26-1 kernel. I have been through the walkthrough here, and the installation process went smoothly.

I downloaded the Zaptel 1.4 source from SVN and it installed without errors. Later, when the errors below started to occur, I tried the 1.2 source. The results for zttest (shown below) were the same for both versions except that version 1.4 reported my verbose test as a positive 400% rather than negative 200%. When I run zttest, this is the result I receive:

Opened pseudo zap interface, measuring accuracy... (shown below)
-201.562500% -200.000000% -200.012207% -201.574707%

(and so on)

With zttest -v, I get this:

8192 samples in 32768 sample intervals -200.000000%
8192 samples in 32897 sample intervals -201.574707%
8192 samples in 32768 sample intervals -200.000000%
8192 samples in 32768 sample intervals -200.000000% ^C

Best: 0.000000 — Worst: -201.574707 — Average: -200.393677

The modules are loaded:

~# lsmod | grep zt
zttranscode 6152 0
ztdummy 3024 0
zaptel 176164 4 zttranscode,ztdummy

~# lsmod | grep zap
zaptel 176164 4 zttranscode,ztdummy
crc_ccitt 2048 1 zaptel

The Asterisk (version 1.4) MeetMe conference allows users to join it, but sound comes through as just a crackling, static-like noise.

The hardware is a Soekris net5501, here are the potentially relevant specs:

  • 433 to 600 Mhz AMD Geode LX single chip processor with CS5536 companion chip
  • 128-1024 Mbyte DDR-SDRAM, soldered on board
  • 4 Mbit BIOS/BOOT Flash
  • CompactFLASH Type I/II socket (8 GB compact flash card installed)
  • USB 2.0 interface, one internal, one external port

Any suggestions would be much appreciated. Will post back if I find more out.