ST-2030 problem

Joined: Mon 06 of Jul, 2009

Re: ST-2030 problem

Posted:Fri 17 of Jul, 2009 (19:43 UTC)
That's magnificent, tuta123. Thank you for this information - as a result my phone is now fully recovered!

I've had need of a serial port at CMOS levels before. An alternative to the level shifter is to open up a USB/232 adapter and pick out the CMOS level signals between the USB IC and the level-shifter. These are separate components at least in a Prolific-based adapter. (Note that the shifter inverts the signals as well.) Pin 3 (Rx) is the receive direction from ST2030 to PC; pin 4 (Tx) is transmit from PC to ST2030.

I couldn't ping the ST2030 from the PC whilst only the boot-loader was running but that didn't stop the TFTP transfer. I also found I had to update the phone progressively from 1.52 to 1.62. Even then I couldn't use 2.67 by TFTP (failed with error 'wrong Flash vendor ID' rather than 'bypassed' for the other uploads). However, once 1.62 was in I could continue with the web interface and load 2.67 that way.

Anyway, again thank you, this worked a treat!
Joined: Mon 29 of Jun, 2009

Re: ST-2030 problem

Posted:Sat 11 of Jul, 2009 (14:56 UTC)
I've managed finally to fix the phone, but solution is not simple. It involves disassembling the phone,
and possibly some soldering of one IC and capacitors
You have to open a phone, and there is a white, 4-pin connector which looks similar to small audio connectors on sound cards.
It has following pinouts: 1-Vcc 2-GND 3-Rx 4-Tx.
Unfortunately, you can not connect this to you PC COM port directly, converter is needed.
You can buy one or build it yourself, nice instructions can be found here:

Once you have everything in order, open you favorite terminal program (Hyper Terminal or similar) and setup you serial port to 115200 N 8 1.

Restart the phone. Lot of information will be shown on your display. At some point, it will display an error and stop. I did not capture this information while I could, so I can not give a details. Restart the phone again. You will see a message to press CTRL-I within 3 seconds. After you do so, regular boot will stop and some basic shell will display. To get the list of available commands, type “help”.
We need 2 commands: “net set” to configure IP address to match your LAN and tftp to transfer and flash the newest firmware.
You will need to setup tftp server on your Pc or laptop. Freeware tftpd32 or similar.
Type ‘net set’ and it will prompt you for IP, subnet and gateway.
Now try to ping your phone from PC. If everything is fine, place the firmware (v2030SG.R11.1.090305.2.67.2.zz) into root of your tftp server.
On phone, type:

tftp <ip_address> v2030SG.R11.1.090305.2.67.2.zz

where ip_address is IP of your PC where tftp server resides.

If everything is setup OK, the file will be transferred and unit flashed.

Phone managed to boot after that, all I had to do is factory reset from phone interface.
After that, you can use WEB browser to configure, admin password is 784518.

Good luck
Joined: Mon 06 of Jul, 2009

Re: ST-2030 problem

Posted:Mon 06 of Jul, 2009 (15:53 UTC)
I'm sure it's not much consolation but the same happened to me. In my case I changed to boot code 1.11 first, then to firmware 1.52 and then saw the same result as you. After trying to reset to factory defaults everything froze with the Loading screen and all lights on. I'll post if I discover anything but I'm not optimistic...
Joined: Mon 29 of Jun, 2009

ST-2030 problem

Posted:Mon 29 of Jun, 2009 (14:28 UTC)
I've tried to upgrade firmware on Thomson ST-2030 to the latest one (2.67) from 1.42, but it failed from both HTTP and TFTP. There is info on some forum that upgrade to 1.5x is required first, and then to 2.67. So I did it (upgrade to 1.53), and message on the browser displayed success and asked to reboot.
After reboot, phone managed to display a menu for a few times, but would hang as soon as DHCP obtained IP address. Without network cable it would not freeze, but whenever I tried to change some of the settings, it just hanged. At some point, phone stopped even booting and now it just displays "loading" forever. Can anything be done or this phone is dead/bricked? What went wrong so I do not make a mistake on other phones? I have to change firmware to support SIP. Any help is appreciated. Thanks.