SIP for Cisco 7940G -- CTLSEP cycling problem

Joined: Fri 04 of Sep, 2009

Re: SIP for Cisco 7940G -- CTLSEP cycling problem

Posted:Fri 18 of Sep, 2009 (15:42 UTC)
I've fixed my problem. There are two elements.
1) None of the sources I listed discussed security. My TFTP server could not respond to requests because its port was blocked.
2) The Cisco format changed. (*X* means bold) Formerly, image version was written P0S3-*08*-11-00. Now it is P0S3-*8*-12-00.
Joined: Fri 04 of Sep, 2009

SIP for Cisco 7940G -- CTLSEP cycling problem

Posted:Fri 04 of Sep, 2009 (15:30 UTC)
I'm trying to follow the Asteriskdocs.org book "Asterisk: the Future of Telephony" and install SIP firmware on a Cisco 7940G phone. I am currently stuck with the phone trying to download CTLSEP<mac>.tlv\000, cycling to look for SEP<mac>.cmf.xml\000, and then back. The message the phone displays is "Configuring CM List". I have read the voip-info.org wiki's "Firmware issues on 7940-7960" page, seen the workaround, tried it, and had no results.

Phone details:
Model Number: CP-7940G. (I could not find "-CH1" or "=" on either the physical phone or in the model information.)
App Load ID: P00308000900. I suspect this translates to 08-9-00.
Boot Load ID: PC0303010100.

In my /tftpboot directory I have:

OS79XX.TXT which has a single line reading: P003-8-12-00

all taken directly from the .zip file.

SIPDefault.cnf with image_version:P0S3... and proxy1_address: <tftp_server_address>
SIP<mac>.cnf copied from Asteriskdocs.org

When those did not work, at the wiki's "Firmware issues on 7940-7960" suggestion I added:
CTLSEP<mac>.tlv — A blank file.
SEP<mac>.cnf.xml — I updated loadInformation for the 7940 to read "P0S3-08-12-00" and processNodeName as <tftp_server_address>.
Adding those two files did nothing. I have tried moving CTLSEP<mac> as it was being queried. I've tried a factory reset of the phone.

I appreciate your help.