[SOLVED] Playback problem with asterisk-1.6 and gsm codec

Joined: Mon 28 of Sep, 2009

[SOLVED] Playback problem with asterisk-1.6 and gsm codec

Posted:Mon 28 of Sep, 2009 (19:29 UTC)
After upgrading to asterisk-1.6 from 1.4, all my system prompts/messages/IVR which are gsm recordings have horrible noisy audio. Other codecs (e.g. user-recorded voicemail greetings) sound fine. For some reason FreePBX converts these user-recorded formats (WAV, wav, gsm) to slinear during Playback and the audio is just fine. But the main system recordings (all in gsm format) are played in gsm codec and the audio quality is very bad. I have set asterisk.conf:internal_timing = yes. But still bad audio for system prompts.

Conversations are crystal clear whether from one Snom SIP phone to another or to/from the PSTN.
Only system prompts/recordings are noisy. I'm not talking about echo. There is no echo problem, just noise.

Any ideas on what could be the problem, or where to begin debugging this?
Thanks for any suggestions.

I downgraded from i686-pc-linux-gnu-4.3.4 to i686-pc-linux-gnu-4.1.2
then recompiled with CFLAGS="-O2 -march=athlon-xp -pipe"

Not sure if this is a bug in the newer gcc compilers or in the gsm assembler optimization.