CISCO 7940 Issues

Joined: Wed 08 of Sep, 2010

CISCO 7940 Issues

Posted:Wed 08 of Sep, 2010 (04:15 UTC)
I am making a new thread because the oldest threads relating to this issue (somewhat) are a couple years old. It's something surprisingly common, and here is my story:

So, having worked at a couple of call centers that used the Cisco 7940 and 7960, I decided I wanted to buy one, so I did. Lo and behold, it turns out that the unit needs POE or a brick in order to turn on. Since I only wanted one phone for home, I decided against buying a POE capable switch. Instead, I bought a brick. When it finally turned on, lo and behold, it has some weird interface that won't let me define SIP parameters. After a couple of days of research, I find out the phone has an SCCP firmware, and now I need to flash it with SIP.

That was another couple of days, finding a good load and making good config files. Kudos's to the Forums here, as their help was invaluable in helping me figure out how to do this surprisingly vaunting task.

So now my phone is SIP enabled, and *properly* configured. Except, it still doesn't register in my PBX. I've spent another two days already, pouring through 3 and 4 year old posts about it, however, all of these posts detail connecting to an asterisk in a local network. What I am trying to accomplish, is to get the CISCO phone to connect to a remote PBX.

The rub is: the PBX doesn't even see attempts by the phone to register. When I use X-Lite, it works. Now, at my office, we use Zed-3 phones, and I brought one home. In exactly 3 minutes, I was making and getting calls from the Zed-3. The CISCO's configuration is, near as I can tell, duplicated, so it *should* work, but it doesn't. The phone is successfully picking up the time from, so I assume Natting is not the problem. Also, there is a small "x" beside the speaker icon right by my extension number, and I don't know if it means anything.

I have telnetted into the phone, (again, thanks to the forums here) and set the debug parameters on. This is what I get:
SIP Phone> 23:13:37:301916 sipTransportSendMessage: Error: dns_gethostbyname() returned error returned error.
23:13:37:301916 LINE 6/1: sipTransportCreateSendMessage : Error: sip_sm_cc_channel_send_buf_fcn() returned error.
23:13:37:301916 LINE 6/1: sipTransportCreateSendMessage : Stored message not sent
23:13:37:301917 SendRequest: Error: sipTransportCreateSendMessage() returned error.
23:13:37:301918 %E600 REG send failure: REGISTER

Anyone have a clue what this means? I'll be happy to post config files if anyone has any experience in getting this setup going.

thank you in advance for any assistance...