Issues getting Day Night mode to work accordingly

infamoose
Joined: Fri 15 of Oct, 2010

Issues getting Day Night mode to work accordingly

Posted:Fri 15 of Oct, 2010 (02:42 UTC)
So here is what I am trying to do. First a brief on my current office setup. 3 extensions in a call group, lets call it group 600. In group 600 are Operator and 2 Receptionist extension(s). This works fine in Day Mode. Calls come into to the appropriate CID number and are routed to call group 600 as "ring all".

Now here is where I am encountering problems. With calls coming in after no pickup the call does not go to the requested destination (extension 100 "busy") voicemail. Instead the call drops off leaving me with the following:


ASTERISK CLI

-- Executing [[email protected]:17] DBdel("SIP/208.85.184.40-08f64ed8", "BLKVM/600/SIP/208.85.184.40-08f64ed8") in new stack
-- DBdel: family=BLKVM, key=600/SIP/208.85.184.40-08f64ed8
-- Executing [[email protected]:18] Goto("SIP/208.85.184.40-08f64ed8", "ext-local|vmb100|1") in new stack
-- Goto (ext-local,vmb100,1)
-- Executing [[email protected]:1] Macro("SIP/208.85.184.40-08f64ed8", "vm|100|BUSY|") in new stack
-- Executing [[email protected]:1] Macro("SIP/208.85.184.40-08f64ed8", "user-callerid|SKIPTTL") in new stack
-- Executing [[email protected]:1] Set("SIP/208.85.184.40-08f64ed8", "AMPUSER=12139241217") in new stack
-- Executing [[email protected]:2] GotoIf("SIP/208.85.184.40-08f64ed8", "0?report") in new stack
-- Executing [[email protected]:3] ExecIf("SIP/208.85.184.40-08f64ed8", "0|Set|REALCALLERIDNUM=12139241217") in new stack
-- Executing [[email protected]:4] Set("SIP/208.85.184.40-08f64ed8", "AMPUSER=") in new stack
-- Executing [[email protected]:5] Set("SIP/208.85.184.40-08f64ed8", "AMPUSERCIDNAME=") in new stack
-- Executing [[email protected]:6] GotoIf("SIP/208.85.184.40-08f64ed8", "1?report") in new stack
-- Goto (macro-user-callerid,s,11)
-- Executing [[email protected]:11] GotoIf("SIP/208.85.184.40-08f64ed8", "1?continue") in new stack
-- Goto (macro-user-callerid,s,20)
-- Executing [[email protected]:20] NoOp("SIP/208.85.184.40-08f64ed8", "Using CallerID "12139241217" <12139241217>") in new stack
-- Executing [[email protected]:2] Set("SIP/208.85.184.40-08f64ed8", "VMGAIN=""") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/208.85.184.40-08f64ed8", "1?vmx|1") in new stack
-- Goto (macro-vm,vmx,1)
-- Executing [[email protected]:1] GotoIf("SIP/208.85.184.40-08f64ed8", "0?s-BUSY|1") in new stack
-- Executing [[email protected]:2] Set("SIP/208.85.184.40-08f64ed8", "MODE=busy") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/208.85.184.40-08f64ed8", "1?notdirect") in new stack
-- Goto (macro-vm,vmx,5)
-- Executing [[email protected]:5] NoOp("SIP/208.85.184.40-08f64ed8", "Checking if ext 100 is enabled: ") in new stack
-- Executing [[email protected]:6] GotoIf("SIP/208.85.184.40-08f64ed8", "1?s-BUSY|1") in new stack
-- Goto (macro-vm,s-BUSY,1)
-- Executing [[email protected]:1] NoOp("SIP/208.85.184.40-08f64ed8", "BUSY voicemail") in new stack
-- Executing [[email protected]:2] Macro("SIP/208.85.184.40-08f64ed8", "get-vmcontext|100") in new stack
-- Executing [[email protected]:1] Set("SIP/208.85.184.40-08f64ed8", "VMCONTEXT=default") in new stack
-- Executing [[email protected]:2] GotoIf("SIP/208.85.184.40-08f64ed8", "0?200:300") in new stack
-- Goto (macro-get-vmcontext,s,300)
-- Executing [[email protected]:300] NoOp("SIP/208.85.184.40-08f64ed8", "") in new stack
-- Executing [[email protected]:3] VoiceMail("SIP/208.85.184.40-08f64ed8", "[email protected]|b") in new stack
== Spawn extension (macro-vm, s-BUSY, 3) exited non-zero on 'SIP/208.85.184.40-08f64ed8' in macro 'vm'
== Spawn extension (macro-vm, s-BUSY, 3) exited non-zero on 'SIP/208.85.184.40-08f64ed8'



ASTERISK CLI END


Hope this can help a more versed individual help me track down the situation. Running v2.6.2.3.

        • Just a side note. When I call from my googlevoice line it goes through to the night mode without fail. Could it be due to the call originating from a 916 area code? Instead of a 213/323 area code? No CLI info during the GoogleVoice call to show as CLI doesn't post any information.****