IAX2 Realtime sound issues

Comment on Asterisk RealTime IAX
Joined: Wed 30 of Mar, 2011

IAX2 Realtime sound issues

Posted:Wed 30 of Mar, 2011 (06:45 UTC)
We have followed the guidelines posted here while installing the Realtime server. SIP users can register and have no issues during calls. The problem that we have faced has multiple dimensions. We create our users on the related MySQL fields (just like we do for SIP).

1. In one installation only Zopier clients were able to register to the server on the IAX side. We have tried other IAX client applicaitons such as Kiax / Diax and none of those users were able to register to the server.
2. In both cases, IAX to IAX calls are established, we do not receive any errors on the CLI, but we hear no sound for both parties. At first we thought that this might be an issue related with codec mismatch, but later discovered that each party could do their echo test without issues.

What do you think is happening here? We have even tried to use the extensions.conf over the database, with no luck.