help configure QOS

keivan
Joined: Thu 22 of Sep, 2016

help configure QOS

Posted:Thu 22 of Sep, 2016 (05:58 UTC)
Hi everybody how is know how i cam optimize the this configuration with QOS
or any mistake in this config
my configuration


hostname Cisco

boot-start-marker
no boot startup-test
boot-end-marker

resource-pool disable
no aaa new-model

resource policy

spe default-firmware spe-firmware-1

ip cef
no ip domain lookup

carrier-id Samand
isdn switch-type primary-net5

voice service pots
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
modem passthrough nse codec g711alaw
sip
registrar server
no call service stop

voice translation-rule 2

application
service test 192.168.0.5

controller E1 3/0
pri-group timeslots 1-31
cablelength medium

controller E1 3/1
pri-group timeslots 1-31
cablelength medium

interface GigabitEthernet0/0
ip address ****************** ****************

no ip route-cache cef
no ip route-cache
no ip mroute-cache
duplex full
speed auto
negotiation auto
no cdp enable

interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
negotiation auto
no cdp enable

interface Serial0/0
no ip address
shutdown
clock rate 2000000
no dce-terminal-timing-enable
no fair-queue

interface Serial0/1
no ip address
shutdown
clock rate 2000000
no dce-terminal-timing-enable
no cdp enable

interface Serial3/0:15
no ip address
encapsulation hdlc
logging event link-status
isdn switch-type primary-net5
isdn incoming-voice modem 64
isdn bchan-number-order ascending
no cdp enable

interface Serial3/1:15
no ip address
encapsulation hdlc
logging event link-status
isdn switch-type primary-net5
isdn incoming-voice modem 64
isdn bchan-number-order ascending
no cdp enable

interface Async1/00
no ip address
encapsulation slip

interface Async1/01
no ip address
encapsulation slip

interface Async1/02
no ip address
encapsulation slip

interface Async1/03
no ip address
encapsulation slip

interface Async1/04
no ip address
encapsulation slip

interface Async1/05
no ip address
encapsulation slip

interface Async1/06
no ip address
encapsulation slip

interface Async1/07
no ip address
encapsulation slip

interface Async1/08
no ip address
encapsulation slip

interface Async1/09
no ip address
encapsulation slip

interface Async1/10
no ip address
encapsulation slip

interface Async1/11
no ip address
encapsulation slip

interface Async1/12
no ip address
encapsulation slip

interface Async1/13
no ip address
encapsulation slip

interface Async1/14
no ip address
encapsulation slip

interface Async1/15
no ip address
encapsulation slip

interface Async1/16
no ip address
encapsulation slip

interface Async1/17
no ip address
encapsulation slip

interface Async1/18
no ip address
encapsulation slip

interface Async1/19
no ip address
encapsulation slip

interface Async1/20
no ip address
encapsulation slip

interface Async1/21
no ip address
encapsulation slip

interface Async1/22
no ip address
encapsulation slip

interface Async1/23
no ip address
encapsulation slip

interface Async1/24
no ip address
encapsulation slip

interface Async1/25
no ip address
encapsulation slip

interface Async1/26
no ip address
encapsulation slip

interface Async1/27
no ip address
encapsulation slip

interface Async1/28
no ip address
encapsulation slip

interface Async1/29
no ip address
encapsulation slip

interface Async1/30
no ip address
encapsulation slip

interface Async1/31
no ip address
encapsulation slip

interface Async1/32
no ip address
encapsulation slip

interface Async1/33
no ip address
encapsulation slip

interface Async1/34
no ip address
encapsulation slip

interface Async1/35
no ip address
encapsulation slip

interface Async1/36
no ip address
encapsulation slip

interface Async1/37
no ip address
encapsulation slip

interface Async1/38
no ip address
encapsulation slip

interface Async1/39
no ip address
encapsulation slip

interface Async1/40
no ip address
encapsulation slip

interface Async1/41
no ip address
encapsulation slip

interface Async1/42
no ip address
encapsulation slip

interface Async1/43
no ip address
encapsulation slip

interface Async1/44
no ip address
encapsulation slip

interface Async1/45
no ip address
encapsulation slip

interface Async1/46
no ip address
encapsulation slip

interface Async1/47
no ip address
encapsulation slip

interface Async1/48
no ip address
encapsulation slip

interface Async1/49
no ip address
encapsulation slip

interface Async1/50
no ip address
encapsulation slip

interface Async1/51
no ip address
encapsulation slip

interface Async1/52
no ip address
encapsulation slip

interface Async1/53
no ip address
encapsulation slip

interface Async1/54
no ip address
encapsulation slip

interface Async1/55
no ip address
encapsulation slip

interface Async1/56
no ip address
encapsulation slip

interface Async1/57
no ip address
encapsulation slip

interface Async1/58
no ip address
encapsulation slip

interface Async1/59
no ip address
encapsulation slip

interface Group-Async0
no ip address
encapsulation slip
no group-range

interface Group-Async1
physical-layer async
no ip address
encapsulation slip

interface Group-Async21
physical-layer async
no ip address
encapsulation slip

no ip http server

access-list 101 permit ip any any
dialer-list 1 protocol ip permit
snmp-server community public RO
snmp-server community Pendar RO

control-plane

voice-port 3/0:D
disc_pi_off
input gain 14
output attenuation -6
echo-cancel coverage 64
no non-linear
playout-delay mode fixed
no comfort-noise
cptone DE

voice-port 3/1:D
disc_pi_off
input gain 14
output attenuation -6
echo-cancel coverage 64
no non-linear
playout-delay mode fixed
no comfort-noise
cptone DE

dial-peer cor custom

dial-peer voice 1 pots
service session
destination-pattern 199T
incoming called-number .
direct-inward-dial
port 3/0:D

dial-peer voice 12 voip
service session
destination-pattern 1118
session protocol sipv2
session target ipv4:***************
session transport udp
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 2 pots
service session
destination-pattern 199T
incoming called-number .
direct-inward-dial
port 3/1:D

dial-peer voice 13 voip
service session
destination-pattern 33333...
session protocol sipv2
session target ipv4:*******************
session transport udp
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 8888 voip
service session
destination-pattern 36668...
session protocol sipv2
session target ipv4:*******************
session transport udp
dtmf-relay rtp-nte
codec g711alaw
no vad

sip-ua
credentials username ****** password 075E701D1F realm *******
authentication username ****** password *******
no remote-party-id
no redirection
srv version 1
retry register 10
timers register 100
registrar ipv4:***************** expires 60
sip-server ipv4:***************

ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3

line con 0
exec-timeout 0 0
password 123
logging synchronous
login local
line aux 0
line vty 0 4
password pendar
login
line 1/00 1/59
modem InOut

scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end



thanks