Discussion: chan_sccp2

Comments Filter

v3 on asterisk 1.4

guys did anyone manage to get v3 to work on asterisk 1.4?

by rnbguy, Sunday 18 of July, 2010 (16:55:29 UTC)
asterisk connection through sccp

Hi,
I'd like to know if i can connect through sccp protocol to cisco call manager 3845 (that only support sccp/skinny clients) using asterisk chan_sccp.
I just want to connect softphones client to asterisk via sip protocol and connect asterisk pbx to cisco call manager.

Thanks in advance,
king regards,

cotoneblues.

by cotoneblues, Monday 25 of February, 2008 (15:06:49 UTC)
chan_sccp with asterisk 1.4.17

All my 7960 features are working with chan_sccp-20071213.

I described my setup on <a href="http://southbrain.com/south/">my website</a>.

by Finesse, Friday 01 of February, 2008 (13:11:31 UTC)
chan_sccp with asterisk 1.4.14 and Adrians Patch

Hiho,

I just moved from Asterisk 1.2 to 1.4.14 and tried to install the chan_sccp drivers. Unfortunately I get the same compiling-errors as mentioned above:

chan_sccp.c: In function ‘reload_config’:
chan_sccp.c:1274: error: incompatible type for argument 1 of ‘ast_inet_ntoa’
chan_sccp.c:1274: error: too many arguments to function ‘ast_inet_ntoa’
chan_sccp.c:1281: error: incompatible type for argument 1 of ‘ast_inet_ntoa’
chan_sccp.c:1281: error: too many arguments to function ‘ast_inet_ntoa’
chan_sccp.c:1285: error: incompatible type for argument 1 of ‘ast_inet_ntoa’
chan_sccp.c:1285: error: too many arguments to function ‘ast_inet_ntoa’
chan_sccp.c:1292: error: incompatible type for argument 1 of ‘ast_inet_ntoa’
chan_sccp.c:1292: error: too many arguments to function ‘ast_inet_ntoa’

I tried the latest version of Adrians patch, but the errors still occure.

Any ideas?

Got one Cisco 7971 and one 7931 for testing purposes and would be glad to get them working.

Thanks
meph

by mephistho, Friday 23 of November, 2007 (11:10:35 UTC)
Chan_sccp & asterisk 1.4.11

Hello

I'm using * 1.4.11, when I try to install chan_sccp-20060408.tar.bz2, I also patch chan_sccp2_1.4.4.diff give me some errors.

chan_sccp.c:1481: error: ‘struct sccp_global_vars’ has no member named ‘localaddr’
chan_sccp.c:1482: error: ‘struct sccp_global_vars’ has no member named ‘localaddr’
chan_sccp.c:1484: error: ‘struct sccp_global_vars’ has no member named ‘sessions_lock’
chan_sccp.c:1485: error: ‘struct sccp_global_vars’ has no member named ‘devices_lock’
chan_sccp.c:1486: error: ‘struct sccp_global_vars’ has no member named ‘lines_lock’
chan_sccp.c:1487: error: ‘struct sccp_global_vars’ has no member named ‘channels_lock’
chan_sccp.c:1488: error: ‘struct sccp_global_vars’ has no member named ‘usecnt_lock’
chan_sccp.c:1489: error: ‘struct sccp_global_vars’ has no member named ‘lock’
chan_sccp.c: At top level:
chan_sccp.c:1496: error: expected ‘)’ before string constant

Someone can try to guide me please.


by tensk8, Tuesday 18 of September, 2007 (17:50:12 UTC)
chan_sccp patch with imap voicemail

Has anyone been able to get Adrian's patch working when IMAP voicemail storage is compiled into 1.4.4/1.4.x? Enabling this causes the phones to hang or be unable to register properly...

by stuart.morgan, Saturday 01 of September, 2007 (23:57:30 UTC)
Re: Asterisk 1.4.5

Apologies to everyone who had trouble with my patch for 1.4.4. The patch was Ok, but back to front. Created in haste and not checked it had to be applied in reverse. I've replaced it with a correct one which I've tested against the latest 1.4.x SVN branch (1.4.7.1). It applies cleanly and works fine on my 7940.

by UriahHeep, Monday 16 of July, 2007 (17:18:43 UTC)
Asterisk 1.4.5

OK, never mind I guess. I looked at the patch file and strangely enough it showed adding everything
I had to take out to get it to compile. Even stranger was when I tried to apply the patch, it said the source
was already patched and asked if I wanted to reverse it.

Well, untared a fresh copy and did a reverse patch on the source code AND IT COMPILED CORRECTLY.

My head hurts.

by kenw, Wednesday 27 of June, 2007 (16:57:03 UTC)
Asterisk 1.4.5

Tried using chan_sccp after additional patching of the source to get it to compile under BOTH 1.4.5 & 1.4.4.
All files compile correctly, but module will no register with Asterisk. Here's the error:

[Jun 27 09:27:34] WARNING[6707]: loader.c:375 load_dynamic_module: Module 'chan_sccp.so' did not register itself during load
[Jun 27 09:27:34] WARNING[6707]: loader.c:614 load_resource: Module 'chan_sccp.so' could not be loaded.


Has anyone else gotten a successful register /use with 1.4.4 or 1.4.5 ?


by kenw, Wednesday 02 of May, 2012 (07:46:55 UTC)
chan_sccp2 fix for 7940/7960 with 8.0.X firmwares

chan_sccp2 7940/7960 patch (we should check load version somewhere in the code)

http://www.nhm.it/sccp_indicate_patch_load_805.patch

If someone would let me know if it works with old firmware versions i will appreciate.
Thanks in advance.

by fsantulli, Wednesday 27 of June, 2007 (13:24:31 UTC)